Erro “Failed to load the JNI shared library” ao abrir o Eclipse

Ao abrir o pela primeira vez Eclipse o usuário se depara com a mensagem de erro “Failed to load the JNI shared library”, este erro acontece devida a diferença de versão do Eclipse e da JVM

Por exemplo: O Eclipse é de 64 Bits e o Java 32 bits.

Para solucionar o problema, você precisa configurar versões compatíveis da JVM. Mas, caso você tenha duas JVM diferentes em sua máquina e não possa removê-las, tenha certeza de que o Eclipse está utilizando a versão correta. Para fazer isso edite o arquivo “eclipse.ini” que se localiza na raiz da pasta de instalação do Eclipse.

Após as linha:

-showsplash
org.eclipse.epp.package.common

Adicione as linhas abaixo, lembre-se que o caminho abaixo é só um exemplo e você deverá colocar o endereço do seu javaw.exe compatível:

-vm
C:\path\to\64bit\java\bin\javaw.exe

Salve o arquivo e inicialize o Eclipse novamente.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *